Cours Google Sheets : validation de données

Comme son nom l'indique, la validation de données permet de s'assurer de la validité des données entrées et d'afficher un message d'erreur ou refuser l'entrée si les données ne sont pas valides.

Cette fonctionnalité permet de valider les données en limitant les choix d'entrées possibles ou en testant la valeur entrée par rapport à un critère défini.

Le fichier d'exemple : lecon-10d.xlsx


Validation en fonction d'une plage

Sélectionnez la plage qui devra contenir des données valides et cliquez sur "Validation de données" dans le menu Données (ou par clic droit) :

google sheets validation donnees

Le critère par défaut est la "Liste créée à partir d'une plage".

Entrez maintenant la plage de cellules qui contient la liste des données valides :

google sheets validation donnees plage

Choisissez s'il faut afficher un avertissement ou s'il faut refuser la saisie en cas de valeur invalide.

Puisque l'option de liste déroulante était cochée, les choix valides sont présentés sous forme de liste déroulante pour simplifier la saisie :

google sheets validation donnees liste deroulante

Validation en fonction d'une liste

A la différence de la validation en fonction d'une plage de cellules, ce critère permet de lister les choix possibles directement dans le champ :

google sheets validation donnees liste

Pour obtenir :

google sheets validation donnees liste deroulante cellule

Validation en fonction d'un nombre

Pour appliquer un critère lié à une valeur numérique, sélectionnez le choix "Nombre" :

google sheets validation donnees nombre

En cochant l'option "Afficher le texte d'aide à la validation", il est possible d'afficher un message informatif :

google sheets validation donnees nombre message

Validation en fonction d'une date

Lorsque le critère est lié à une date, sélectionnez le choix "Date" :

google sheets validation donnees date

Validation en fonction d'une formule

Pour des validations de données plus personnalisées, choisissez la validation par formule.

Dans cet exemple, la formule =NB.SI($B$2:$B$16;B2)=1 affichera un avertissement en cas de doublons :

google sheets validation donnees formule

Le "C" est entré à double, l'avertissement est alors affiché :

google sheets validation donnees doublons
Télécharger ce cours au format PDF