Fonction Google Sheets : ARRAYFORMULA

La fonction ARRAYFORMULA permet d'afficher des valeurs issues d'une formule de tableau sur plusieurs lignes et/ou colonnes, et d'utiliser avec des tableaux des fonctions ne prenant pas en charge ces derniers.

Les exemples ci-dessous devraient vous aider à mieux comprendre l'utilité de cette fonction très particulière et comment l'utiliser.

Utilisation :

=ARRAYFORMULA(formule_tableau)


Exemple d'utilisation simple

Pour faire une addition simple (et sans fonction), il faut entrer la formule suivante =A2+B2 :

google sheets addition arrayformula

Il faut ensuite recopier la formule vers le bas :

google sheets addition recopie arrayformula

Dans ce cas, il y a donc une formule dans chacune des 8 cellules.

Eh bien, la fonction ARRAYFORMULA permet d'afficher les mêmes résultats mais en entrant la formule une fois et dans une seule cellule !

Pour faire cela, entrez la fonction ARRAYFORMULA puis A2+B2 et remplacez les cellules par les plages entières A2:A9+B2:B9.

La formule est donc ici =ARRAYFORMULA(A2:A9+B2:B9) :

google sheets fonction arrayformula

La formule (entrée uniquement dans la cellule C2) renverra ensuite le résultat de l'addition de chaque paire de nombre :

google sheets fonction arrayformula exemple

En cas de besoin, vous pouvez copier le fichier de cet exemple.

Exemple d'utilisation avec une fonction

Dans l'exemple suivant =SI(B2<>"";B2*C2;""), la fonction SI teste si la quantité a été renseignée et calcule ensuite le montant total (cet exemple est une copie de celui de la fonction SI) :

google sheets fonction si non vide

Pour remplacer cette colonne de formules par une fonction ARRAYFORMULA, copiez la fonction SI dans la fonction ARRAYFORMULA et remplacez les références aux cellules par les références vers les plages de cellules (par exemple, au lieu de B2, entrez la plage B2 à B7).

La formule devient alors =ARRAYFORMULA(SI(B2:B7<>"";B2:B7*C2:C7;"")) :

google sheets fonction arrayformula si

La formule (entrée uniquement dans la cellule D2) renverra donc le résultat pour les 6 lignes :

google sheets fonction arrayformula si condition

En cas de besoin, vous pouvez copier le fichier de cet exemple.

Pour ajouter automatiquement la fonction ARRAYFORMULA à la formule en cours, appuyez sur Ctrl + Maj + Entrée.