Fonction Google Sheets : SOMMEPROD

La fonction SOMMEPROD (ou SUMPRODUCT en anglais) calcule la somme de deux plages de valeurs (ou plus) multipliées entre elles, ligne par ligne.

Utilisation :

=SOMMEPROD(plage_1; plage_2)

ou

=SOMMEPROD(plage_1; plage_2; plage_3; etc)


Exemple d'utilisation

Pour mieux comprendre la fonction SOMMEPROD et à quoi correspond sa définition "calcul de la somme des produits", voici pour commencer un tableau simple :

google-sheets-fonction-somme - sommeprod

Dans ce tableau, les coûts totaux sont les produits des colonnes B et C =B2*C2 et le TOTAL est la somme des différents produits =SOMME(D2:D11).

L'objectif maintenant est d'obtenir le même résultat en utilisant SOMMEPROD et sans la colonne des coûts totaux :

google-sheets-total-tableau - sommeprod

Entrez dans la fonction SOMMEPROD, les 2 plages de cellules contenant les données à multiplier entre-elles (ligne par ligne) et dont vous souhaitez obtenir la somme :

google-sheets-fonction-sommeprod - sommeprod

La formule =SOMMEPROD(B2:B11;C2:C11) renvoie bien la somme des produits comme dans le premier tableau :

google-sheets-fonction-sommeprod-somme-total - sommeprod

Exemple d'utilisation avec 3 plages

En ajouant une troisième plage, la fonction SOMMEPROD renverra alors la somme des produits des 3 plages.

Par exemple, en ajoutant une colonne avec des cases à cocher, seules les lignes dont la case est cochée pourront être comptabilisées :

=SOMMEPROD(B2:B11;C2:C11;D2:D11)

google-sheets-fonction-sommeprod-cases-a-cocher - sommeprod
Une case à cocher renvoie soit VRAI (= 1) soit FAUX (= 0), chaque ligne est donc multipliée par 1 ou par 0 en fonction de la case à cocher.

Exemple d'utilisation avec une condition

Pour comptabiliser une plage en fonction d'une condition (au lieu des cases à cocher du précédent exemple), entrez la plage suivie de la condition.

Par exemple, pour comptabiliser uniquement les lignes dont la quantité est supérieure à 100, entrez :

=SOMMEPROD(B2:B11;C2:C11;B2:B11>100)

google-sheets-fonction-sommeprod-condition - sommeprod

De la même manière qu'avec les cases à cocher, cette 3e plage renverra VRAI (= 1) ou FAUX (= 0) en fonction de la condition >100 et permettra de comptabiliser uniquement les lignes répondant à ce critère.

En cas de besoin, vous pouvez copier le fichier avec ces exemples.