Cours Google Sheets : fonction SI et imbrications

Référence aux cellules

Au lieu de chercher à afficher "Oui" et "Non" en fonction de l'âge comme c'est le cas à la page précédente, il est également possible d'afficher une valeur contenue dans une cellule.


L'objectif est maintenant d'afficher un tarif en fonction de l'âge :

google sheets fonction tarif si imbriquee

Les textes "Oui" et "Non" sont donc remplacés par des références vers les tarifs =SI(B2>=18;B12;B11).

Sans oublier d'ajouter des $ aux références des tarifs =SI(B2>=18;$B$12;$B$11) pour éviter de les décaler au moment de les recopier :

google sheets fonction si tarif imbriquee

Les tarifs sont correctement affichés après recopie :

google sheets fonction tarifs si imbriquee

Imbriquer une fonction

Dans certains cas, il sera nécessaire d'imbriquer plusieurs fonctions pour arriver au résultat souhaité.

Par exemple, si un 3e tarif est ajouté :

google sheets fonction 3 tarifs si imbriquee

Dans ce cas, si la personne a plus de 18 ans, 2 tarifs restent possibles (adulte et retraité). Il faudra donc ajouter une nouvelle condition SI pour vérifier si cette personne est retraitée ou non et afficher le bon tarif.

Pour faire cela, au lieu d'entrer une référence vers le tarif adulte si la personne a 18 ans ou plus, entrez une nouvelle fonction SI :

google sheets fonction si imbrique imbriquee

Et complétez cette seconde fonction SI SI(B2<65;$B$12;$B$13) :

google sheets fonction si imbriques imbriquee

Cette formule contenant 2 fonctions =SI(B2>=18;SI(B2<65;$B$12;$B$13);$B$11) permet d'afficher maintenant les 3 tarifs :

google sheets fonction si imbrication imbriquee
Télécharger ce cours au format PDF