Fonction Google Sheets : RECHERCHEV

La fonction RECHERCHEV (ou VLOOKUP en anglais) recherche une valeur dans la première colonne d'une plage de cellules et retourne ensuite la valeur d'une cellule qui se situe sur la même ligne.

Utilisation :

=RECHERCHEV(clé_recherche; plage; index; est_trié)


Exemple d'utilisation

L'objectif ici est de pouvoir entrer le numéro de dossier dans la cellule E2 pour obtenir ensuite automatiquement les informations souhaitées dans les cellules bleues.

Pour commencer, la formule de la cellule G2 devra retourner le nom de la ville :

google sheets recherchev

Entrez dans la fonction RECHERCHEV :

  • "clé_recherche" : la valeur à rechercher dans la première colonne de la "plage" (ici, le numéro de dossier)
  • "plage" : la plage de cellules qui contient l'ensemble des données
  • "index" : le numéro de colonne de la "plage" qui contient le résultat à renvoyer (ici, la colonne 2 pour la ville)
  • "est_trié" : 0 pour rechercher la valeur exacte de "clé_recherche" ou 1 pour renvoyer la valeur la plus proche (à condition que la colonne soit triée), 0 est la valeur recommandée dans la plupart des cas

La formule est ici =RECHERCHEV(E2;A2:C11;2;0) :

google sheets fonction recherchev

Pour afficher ensuite le nombre de points, copiez simplement la formule et modifiez le numéro de colonne (remplacez 2 par 3) :

google sheets fonction recherchev recherche
Dans ce cas, si le numéro de dossier n'est pas trouvé, une erreur est retournée. Pour renvoyer une valeur à la place de cette erreur, utilisez la fonction SIERREUR.
Puisque la fonction RECHERCHEV recherche la valeur dans la première colonne de la plage, les résultats ne peuvent donc pas se situer à gauche de la colonne de recherche. Pour effectuer une recherche dans une colonne qui n'est pas forcément la première de la plage, utilisez la combinaison de fonctions INDEX + EQUIV.

En cas de besoin, vous pouvez télécharger le fichier de cet exemple : recherchev.xlsx