Fonction Google Sheets : SIERREUR

La fonction SIERREUR (ou IFERROR en anglais) retourne une valeur si celle-ci n'est pas une erreur ou une autre valeur en cas d'erreur.

Utilisation :

=SIERREUR(valeur, valeur_si_erreur)


Cas pratique

L'exemple utilisé pour la fonction RECHERCHEV sera notre point de départ.

La fonction RECHERCHEV renvoie ici le nombre de points en fonction du numéro de dossier entré dans la cellule E2 :

google sheets fonction recherchev sierreur

Dans ce cas, si le numéro de dossier n'est pas trouvé, une erreur est renvoyée :

google sheets fonction recherchev erreur sierreur

Pour éviter d'afficher cette erreur (sans la fonction SIERREUR), il faudrait utiliser la fonction SI ainsi qu'une seconde fonction pour vérifier s'il y a une erreur et renvoyer ensuite le résultat de la fonction RECHERCHEV ou une autre valeur en cas d'erreur :

=SI(ESTNA(RECHERCHEV(E2;A2:C11;3;0));"-";RECHERCHEV(E2;A2:C11;3;0))

google sheets fonction recherchev si estna sierreur

Dans ce cas, la fonction RECHERCHEV est présente à double et une fonction supplémentaire a dû être ajoutée.

La fonction SIERREUR permet de simplifier la formule en testant la valeur retournée par la fonction RECHERCHEV et en renvoyant directement cette même valeur s'il n'y a aucune erreur (ou une autre valeur en cas d'erreur) :

=SIERREUR(RECHERCHEV(E2;A2:C11;3;0);"-")

google sheets fonction recherchev sierreur

En cas de besoin, vous pouvez télécharger le fichier de cet exemple : sierreur.xlsx