Fonction Google Sheets : SI

La fonction SI (ou IF en anglais) permet d'afficher une valeur parmi 2 possibilités en fonction d'une condition.

Utilisation :

=SI(condition; valeur_si_vrai; valeur_si_faux)


Exemple d'utilisation

Une utilisation courante de la fonction SI est de tester si une cellule est vide avant d'afficher un résultat.

Dans cet exemple, le total ne doit être calculé et affiché que si la quantité est renseignée =SI(B2<>"";B2*C2;"") :

google-sheets-fonction-si-non-vide - si

En cas de besoin, vous pouvez télécharger le fichier de cet exemple : si.xlsx

Explications très détaillées

Pour mieux comprendre comment utiliser la fonction SI (et les fonctions d'une manière générale), consultez la page de la fonction SI du cours Google Sheets.

Un second exemple avec des fonctions SI imbriquées est également disponible.