Fonction Google Sheets : REGEXMATCH (3/3)

Test d'une adresse email

Une regex simplifiée pour tester la validité d'une adresse email pourrait ressembler à "^[\w.-]+@[\w.-]{2,}\.[a-z]{2,}$".


Pour valider cette regex le texte doit :

google sheets fonction regexmatch email 3
Le raccourci \w équivaut à [a-zA-Z0-9_], il ne comprend donc aucun caractère accentué.

Texte contenant ... puis ...

La regex "regex.*amusant" vérifie si le texte contient "regex" puis "amusant" plus loin sur la même ligne :

google sheets fonction regexmatch et 3

Parenthèses

La regex "^\d{4}-\d{4}-\d{4}-\d{4}$" vérifie ici si le texte correspond exactement à la structure souhaitée (soit 4x 4 chiffres séparés par des "-") :

google sheets fonction regexmatch numero licence 3

Vous pouvez remarquer que l'expression -\d{4} est présente à l'identique 3 fois de suite. Pour indiquer que cette partie doit être répétée 3 fois, ajoutez des parenthèses suivi d'un quantificateur (-\d{4}){3}.

La regex devient donc "^\d{4}(-\d{4}){3}$" :

google sheets fonction regexmatch parentheses 3
Les parenthèses permettent également de capturer des parties du texte, elles seront utilisées avec les fonctions REGEXREPLACE et REGEXEXTRACT.

Parenthèses et alternatives

La regex "^https://(www\.)?(excel|sheets)-pratique\.com" vérifie si le texte est une URL du site "excel-pratique.com" ou du site "sheets-pratique.com" :

Pour valider cette regex le texte doit :

google sheets fonction regexmatch url site 3

Fonction REGEXMATCH

Comme vous le savez, la fonction REGEXMATCH renvoie VRAI ou FAUX en fonction du texte et de l'expression régulière. Vous pouvez donc combiner cette fonction avec d'autres pour retourner des valeurs différentes.

Par exemple avec la fonction SI :

=SI(REGEXMATCH(A2;"^https://(www\.)?(excel|sheets)-pratique\.com");"URL valide ;-)";"URL invalide ...")

google sheets fonction regexmatch si 3

Vous pouvez même vous en servir pour vos mises en forme conditionnelles :

google sheets fonction regexmatch mfc 3

Fonction REGEXREPLACE

La fonction REGEXREPLACE effectue des remplacements dans le texte en fonction d'une regex.

Des exemples d'utilisation sont disponibles sur la page de la fonction REGEXREPLACE.

Fonction REGEXEXTRACT

La fonction REGEXEXTRACT extrait une ou plusieurs parties du texte en fonction d'une regex.

Des exemples d'utilisation sont disponibles sur la page de la fonction REGEXEXTRACT.