Fonction Google Sheets : SOMME.SI

La fonction SOMME.SI (ou SUMIF en anglais) permet d'effectuer la somme d'une plage de cellules en fonction d'un critère.

Utilisation :

=SOMME.SI(plage; critère)

ou (si la plage pour la somme est différente)

=SOMME.SI(plage; critère; somme_plage)


Exemple d'utilisation

La fonction SOMME.SI sera utilisée ici pour calculer le montant total des impayés :

google-sheets-total-impayes - somme-si

La condition pour cette somme sera la date de paiement (vide = impayé, non vide = payé).

Entrez dans la fonction SOMME.SI :

  • "plage" : la plage de cellules dans laquelle le critère sera vérifié (ici, les dates de paiement)
  • "critère" : le critère "" (= vide)
  • "somme_plage" : la plage de cellules qui sera utilisée pour le calcul de la somme (ici, les montants).

La formule est ici =SOMME.SI(C2:C11;"";B2:B11) :

google-sheets-somme-si-vide - somme-si

Pour obtenir le total des montants payés à partir de la même formule, remplacez le critère "" (= vide) par le critère "<>" (différent de vide) =SOMME.SI(C2:C11;"<>";B2:B11) :

google-sheets-somme-si-non-vide - somme-si

En cas de besoin, vous pouvez télécharger le fichier de cet exemple : somme.si.xlsx